LaTeX forum ⇒ GeneralInstallation Issue for Document Class

LaTeX specific issues not fitting into one of the other forums of this category.
john84141
Posts: 4
Joined: Fri May 11, 2012 10:10 am

Installation Issue for Document Class

Postby john84141 » Fri May 11, 2012 10:12 am

hello,

I have Ubuntu 12.04 and I'm trying to install a IEEE template to create a .tex document. I have tried both methods of the following tutorial, but none worked:
https://softwareexperiments.wordpress.c ... in-ubuntu/
When I try to compile it, it outputs errors like these:
  1. ! I can't find file `nullfont'. <*> ...ljfour; mag:=1; nonstopmode; input nullfont Please type another input file name ! Emergency stop. <*> ...ljfour; mag:=1; nonstopmode; input nullfont Transcript written on mfput.log.
  2.  
  3. ! I can't find file `pplr7t'. <*> ...:=ljfour; mag:=1; nonstopmode; input pplr7t Please type another input file name ! Emergency stop. <*> ...:=ljfour; mag:=1; nonstopmode; input pplr7t Transcript written on mfput.log. grep: pplr7t.log: No such file or directory

I don't understand what's wrong, I was able to make it work on a 10.04 seamlessly.

Link:
BBcode:
HTML:
Hide post links
Show post links

User avatar
Stefan Kottwitz
Site Admin
Posts: 7804
Joined: Mon Mar 10, 2008 9:44 pm
Location: Hamburg, Germany
Contact:

Postby Stefan Kottwitz » Fri May 11, 2012 10:24 am

Hi John,

welcome to the board!

The second message probably means that the Palatino font is missing on your system.

Perhaps post the complete .log file as attachment. For this, click on "Upload attachment" below the edit text field when writing a post.

Stefan
Site admin

Link:
BBcode:
HTML:
Hide post links
Show post links

john84141
Posts: 4
Joined: Fri May 11, 2012 10:10 am

Postby john84141 » Fri May 11, 2012 11:01 am

hello,
thanks for the prompt answer.
Yes it might be that, I just installed this new system, and I didn't install any fonts yet, so if there are patent issues, maybe some of them aren't given by default.
I tried installing the package 'mss-corefonts-installer' but the same errors are displayed. What should I do to install the missing fonts ?

Link:
BBcode:
HTML:
Hide post links
Show post links

User avatar
Stefan Kottwitz
Site Admin
Posts: 7804
Joined: Mon Mar 10, 2008 9:44 pm
Location: Hamburg, Germany
Contact:

Postby Stefan Kottwitz » Fri May 11, 2012 11:26 am

I would install the newest TeX Live over the internet, not the Ubuntu version from 2009. Perhaps this solves the issue. Furthermore, there's a script called getnonfreefonts which you could use.

Regarding \nullfont, from the TeXbook:

The primitive control sequence \nullfont stands for a font that
has no characters. This font is always present, in case you haven't
specified any others.


Please show a small Infominimal working example, which produces this error, so we see which packages and which settings are involved. Furthermore, please post your .log file.

Stefan
Site admin

Link:
BBcode:
HTML:
Hide post links
Show post links

dafrick
Posts: 1
Joined: Wed Jun 13, 2012 7:01 pm

Postby dafrick » Wed Jun 13, 2012 7:03 pm

I had the same problem, also using Ubuntu 12.04. I solved it (as suggested here http://tex.stackexchange.com/questions/ ... tion-issue ) by installing the package 'texlive-fonts-recommended'.
Hope this helps.

Link:
BBcode:
HTML:
Hide post links
Show post links


Return to “General”

Who is online

Users browsing this forum: Bing [Bot] and 4 guests